Arethusa forum

Arethusa discussion forums.

You are not logged in.

Announcement

Registration is not required to post, but is required to post links.

#1 2016-05-17 13:16:42

Zero
Moderator

VPN v3 compatibility notes

Linux:
The v3 documentation for Ubuntu 16.04 was published a few weeks ago.
Aside from the fact that you need to disable dnsmasq, Ubuntu 16.04 is perfectly compatible with the v3 VPN.
Any distro based on Ubuntu 16.04 should also be compatible.

However the same can't be said of older distros, especially if you want to use NetworkManager. You need a very recent version of NetworkManager to be able to successfully import a v3 configuration file.

The openvpn version in Debian 8 (jessie) is compatible with the v3 VPN, but not NetworkManager.

Ubuntu 14.04, Debian 7, and derived distros are too old. You can still compile a newer openvpn version and connect using command line, as long as your openssl installation supports TLS 1.2 (if it doesn't, your system is outdated and insecure).


For v1/v2 users:
All v3 docs can also be used with v1/v2 configuration files, if you include the certificate in the configuration file.
In fact we will probably delete the v1/v2 docs soon, given how outdated they are.


Last minute information:
We've heard reports that Windows 10 insider build 14332 crashes (blue screen) when connecting to an OpenVPN VPN.
At the moment we don't know if it was fixed in build 14342 or if Microsoft is even aware of the bug.

Offline

#2 2016-05-17 13:16:55

Zero
Moderator

Re: VPN v3 compatibility notes

Français:


Linux:
La documentation v3 pour Ubuntu 16.04 a été publiée il y a quelques semaines.
À part qu'il faut désactiver dnsmasq, Ubuntu 16.04 est parfaitement compatible avec le VPN v3.
Toute distro basée sur Ubuntu 16.04 devrait aussi être compatible.

Par contre ce n'est pas le cas des distros plus anciennes, surtout si vous voulez utiliser NetworkManager. Vous avez besoin d'une version très récente de NetworkManager pour arriver à importer correctement un fichier de configuration v3.

La version d'openvpn dans Debian 8 (jessie) est compatible avec le VPN v3, mais pas NetworkManager.

Ubuntu 14.04, Debian 7, et distros dérivées sont trop vieilles. Vous pouvez toujours compiler une version plus récente d'openvpn et vous connecter en ligne de commande, du moment que votre installation openssl supporte TLS 1.2 (si ce n'est pas le cas, votre système est périmé et dangereux).


Pour les utilisateurs v1/v2:
Toutes les documentations v3 peuvent aussi être utilisées avec les fichiers de configuration v1/v2, si vous incluez le certificat dans le fichier de configuration.
En fait nous allons probablement effacer les docs v1/v2 bientôt, étant donné qu'elles sont largement périmées.


Information de dernière minute:
D'après certaines informations, Windows 10 insider build 14332 crash (écran bleu) en se connectant à un VPN OpenVPN.
Pour le moment nous ne savons pas si cela a été fixé dans le build 14342 ou même si Microsoft est au courant du bug.

Offline

Board footer

Powered by FluxBB